{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-12241 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-12241 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-12241 is a medium-severity cross-site scripting vulnerability in mihail-barinov Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-12241 and fix it if it is affected.\n\nWhat it is: CVE-2026-12241 is a medium-severity cross-site scripting vulnerability in mihail-barinov Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-12241 in the wild and no public exploit code.\n\nAffected product: mihail-barinov Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-12241/ (Markdown: https://insights.sbomify.com/CVE-2026-12241/index.md)","id":"CVE-2026-12241","markdown":"https://insights.sbomify.com/CVE-2026-12241/index.md","name":"CVE-2026-12241","record":{"aliases":["GHSA-4jg7-xq33-668f"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers with Contributor access can inject malicious scripts via improperly escaped product labels in this WooCommerce plugin.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce","id":"CVE-2026-12241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"AdRotate Banner Manager \u003c= 5.17.7 - Authenticated (Contributor+) PHP Code Injection via 'banner' Shortcode Attribute","id":"CVE-2026-12242"},"packages":[],"prev":{"headline":"Deserialization in Export User Data","id":"CVE-2026-12240"},"products":["Advanced Woo Labels – Product Labels \u0026 Badges for WooCommerce"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-03","vendors":["mihail-barinov"]},"summary":"Authenticated attackers with Contributor access can inject malicious scripts via improperly escaped product labels in this WooCommerce plugin.","url":"https://insights.sbomify.com/CVE-2026-12241/"}