# CVE-2026-12252: Untrusted JAR Code Execution in Multiple Stanford Interface Classes in nltk/nltk

> Attackers can execute arbitrary code by providing malicious JAR files to Stanford interface classes in the NLTK library due to missing integrity checks.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-12252, ECHO-aca5-37c5-5309, GHSA-9r6g-266r-89x4, MINI-j5j2-v7mg-2rqv, PYSEC-2026-2085, UBUNTU-CVE-2026-12252

## What is CVE-2026-12252?

CVE-2026-12252 is a high-severity code injection vulnerability in nltk/nltk, published on 4 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In nltk/nltk versions 3.9.3 and earlier, five Stanford interface classes (StanfordPOSTagger, StanfordNERTagger, StanfordParser, StanfordDependencyParser, and StanfordNeuralDependencyParser) are vulnerable to untrusted JAR code execution. These classes accept user-controllable JAR paths and execute them via the `java()` function, which invokes `subprocess.Popen()` without integrity verification. This vulnerability is identical to CVE-2026-0848, which was fixed for StanfordSegmenter by adding SHA256 verification. However, the fix was not applied to these additional classes, leaving them susceptible to arbitrary code execution when loading untrusted JAR files.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-12252?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.9.4 |
| `nltk` | PyPI | All versions | 3.9.4 |
| `nltk` | PyPI | All versions | 3.9.4 |

Products: Nltk Nltk.

## How do I fix CVE-2026-12252?

Upgrade nltk to 3.9.4 or later.

## Is CVE-2026-12252 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12252 exists.

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12252 and fix it if it is affected.

What it is: CVE-2026-12252 is a high-severity code injection vulnerability in nltk/nltk, published on 4 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12252 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.9.4
- nltk (PyPI): affected all versions; fixed in 3.9.4
- nltk (PyPI): affected all versions; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12252/ (Markdown: https://insights.sbomify.com/CVE-2026-12252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12252
- OSV: https://osv.dev/vulnerability/CVE-2026-12252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12252/
Summaries are generated and may contain mistakes; the official description above is the record.
