CVE-2026-12261 Improper Access Control in nltk/nltk
Attackers can poison shared NLTK resources by overwriting trusted models, potentially leading to code execution in downstream applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-12261?
CVE-2026-12261 is a medium-severity missing authorization vulnerability in nltk/nltk, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A vulnerability in `nltk.downloader` in nltk/nltk versions <= 3.9.4 allows for cross-package resource and model poisoning. The downloader extracts package archives into shared namespaces such as `corpora/` and `taggers/` instead of package-isolated roots, and validates package integrity only after the archive has been written and extracted. This design flaw enables one package to overwrite another package's trusted resources within the same namespace, making the changes immediately active through ordinary NLTK APIs. This issue persists across fresh interpreter restarts and can affect downstream workflows, including machine learning pipelines and reproducibility-sensitive environments.
Weakness: CWE-284
Which versions are affected by CVE-2026-12261?
3 open source packages ship an affected version, including nltk. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
nltk PyPI | All versions | 3.10.0 |
nltk PyPI | All versions | 3.10.0 |
nltk PyPI | All versions | 3.10.0 |
Products include Nltk Nltk.
How do I fix CVE-2026-12261?
Upgrade nltk to 3.10.0 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-12261 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12261 exists.
Other vulnerabilities in nltk/nltk
- CVE-2026-0848 Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading
- CVE-2025-14009 Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution
- CVE-2026-78683 NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization
- CVE-2026-79657 NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization
- CVE-2026-79675 NLTK before 3.10.3 JVM Argument Injection via Per-Call Options
Sources
Also known as DEBIAN-CVE-2026-12261, ECHO-5b86-3218-603d, GHSA-ffj6-66c4-86gw, MINI-crj8-c9rg-7cf7, PYSEC-2026-3954, UBUNTU-CVE-2026-12261.