# CVE-2026-12261: Improper Access Control in nltk/nltk

> Attackers can poison shared NLTK resources by overwriting trusted models, potentially leading to code execution in downstream applications.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 7 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-12261, ECHO-5b86-3218-603d, GHSA-ffj6-66c4-86gw, MINI-crj8-c9rg-7cf7, PYSEC-2026-3954, UBUNTU-CVE-2026-12261

## What is CVE-2026-12261?

CVE-2026-12261 is a medium-severity missing authorization vulnerability in nltk/nltk, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in `nltk.downloader` in nltk/nltk versions <= 3.9.4 allows for cross-package resource and model poisoning. The downloader extracts package archives into shared namespaces such as `corpora/` and `taggers/` instead of package-isolated roots, and validates package integrity only after the archive has been written and extracted. This design flaw enables one package to overwrite another package's trusted resources within the same namespace, making the changes immediately active through ordinary NLTK APIs. This issue persists across fresh interpreter restarts and can affect downstream workflows, including machine learning pipelines and reproducibility-sensitive environments.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-12261?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |

Products: Nltk Nltk.

## How do I fix CVE-2026-12261?

Upgrade nltk to 3.10.0 or later.

## Is CVE-2026-12261 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12261 exists.

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12261 and fix it if it is affected.

What it is: CVE-2026-12261 is a medium-severity missing authorization vulnerability in nltk/nltk, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12261 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12261/ (Markdown: https://insights.sbomify.com/CVE-2026-12261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12261
- OSV: https://osv.dev/vulnerability/CVE-2026-12261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12261/
Summaries are generated and may contain mistakes; the official description above is the record.
