# CVE-2026-12372: Server-Side Request Forgery (SSRF) in nltk/nltk

> An SSRF vulnerability in NLTK allows attackers to bypass network restrictions and access internal shared-address-space hosts via crafted URLs.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2026
- **Updated:** 12 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-12372, ECHO-55af-12c6-457b, GHSA-2jhm-w3mp-jcwr, MINI-ccv3-jffx-xmp2, PYSEC-2026-3955, UBUNTU-CVE-2026-12372, openSUSE-SU-2026:11510-1

## What is CVE-2026-12372?

CVE-2026-12372 is a low-severity server-side request forgery vulnerability in nltk/nltk, published on 9 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in nltk/nltk versions 3.9.4 and the current develop branch. The `nltk.pathsec.validate_network_url()` function, intended to prevent SSRF by rejecting internal network addresses, fails to reject IPs in the RFC 6598 shared address space (`100.64.0.0/10`). This occurs because Python's `ipaddress` module does not classify such addresses as `is_private` or `is_global`, and the current guard only checks `is_private` and a few explicit categories. An attacker who can influence a URL passed to NLTK's network-loading helpers can exploit this vulnerability to make a strict-mode application send requests to shared-address-space hosts, potentially exposing non-public infrastructure reachable from the application host. The impact is limited to SSRF-style confidentiality exposure, with no code execution claimed.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-12372?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions to 3.9.4 | None |
| `nltk` | PyPI | All versions | 3.10.0 |
| `nltk` | PyPI | All versions | 3.10.0 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.10.2-1.1 |

Products: Nltk Nltk.

## How do I fix CVE-2026-12372?

Upgrade nltk to 3.10.0 or later.

## Is CVE-2026-12372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12372 exists.

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12372 and fix it if it is affected.

What it is: CVE-2026-12372 is a low-severity server-side request forgery vulnerability in nltk/nltk, published on 9 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12372 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions up to 3.9.4; no fix listed
- nltk (PyPI): affected all versions; fixed in 3.10.0
- nltk (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12372/ (Markdown: https://insights.sbomify.com/CVE-2026-12372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12372
- OSV: https://osv.dev/vulnerability/CVE-2026-12372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12372/
Summaries are generated and may contain mistakes; the official description above is the record.
