# CVE-2026-1245: CVE-2026-1245

> Attackers can execute arbitrary JavaScript code via unsanitized parser field names or encoding parameters in the binary-parser library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 21 Jan 2026
- **Also known as:** GHSA-m39p-34qh-rh3w

## What is CVE-2026-1245?

CVE-2026-1245 is a medium-severity code injection vulnerability in binary-parser, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A code injection vulnerability in the binary-parser library prior to version 2.3.0 allows arbitrary JavaScript code execution when untrusted values are used in parser field names or encoding parameters. The library directly interpolates these values into dynamically generated code without sanitization, enabling attackers to execute arbitrary code in the context of the Node.js process.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-1245?

2 open source packages ship an affected version, including binary-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `binary-parser` | npm | All versions | 2.3.0 |
| `binary-parser` | npm | All versions | 2.3.0 |

Products: Keichi Binary-Parser.

## How do I fix CVE-2026-1245?

Upgrade binary-parser to 2.3.0 or later.

## Is CVE-2026-1245 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1245 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1245 and fix it if it is affected.

What it is: CVE-2026-1245 is a medium-severity code injection vulnerability in binary-parser, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1245 exists.

Affected packages and fixed versions:
- binary-parser (npm): affected all versions; fixed in 2.3.0
- binary-parser (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1245/ (Markdown: https://insights.sbomify.com/CVE-2026-1245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1245
- OSV: https://osv.dev/vulnerability/CVE-2026-1245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1245/
Summaries are generated and may contain mistakes; the official description above is the record.
