# CVE-2026-12491: vLLM: image EXIF Rotation & PNG tRNS Transparency Not Normalized, Causing Mismatch Between Model Input and Expectations

> Improper image metadata handling in vLLM causes model input distortion, potentially leading to incorrect inference results.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-8jr5-v98p-w75m, MINI-33jp-mfhh-vjp9, MINI-364f-6mjv-mhrh, MINI-g835-hm8q-2fpg, PYSEC-2026-3406

## What is CVE-2026-12491?

CVE-2026-12491 is a medium-severity vulnerability in Red Hat AI Inference Server, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in vLLM, an open-source library for large language model inference. This vulnerability arises from improper handling of image metadata, specifically EXIF orientation and PNG transparency (tRNS) data, during image processing. When images are converted to RGB, transparency information may be implicitly discarded or remapped, leading to unexpected rendering of transparent pixels and distortion of input content. This can result in the model misinterpreting image content, potentially affecting the integrity of processed data.

Weakness: CWE-115 (Misinterpretation of Input)

## Which versions are affected by CVE-2026-12491?

3 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.11.0 to 0.23.0 | None |
| `vllm` | PyPI | From 0.11.0 | 0.24.0 |
| `vllm` | PyPI | From 0.11.0 | 0.24.0 |

## How do I fix CVE-2026-12491?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-12491 being exploited?

There is no known exploitation of CVE-2026-12491 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12491 and fix it if it is affected.

What it is: CVE-2026-12491 is a medium-severity vulnerability in Red Hat AI Inference Server, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-12491 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.11.0 up to 0.23.0; no fix listed
- vllm (PyPI): affected from 0.11.0; fixed in 0.24.0
- vllm (PyPI): affected from 0.11.0; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12491/ (Markdown: https://insights.sbomify.com/CVE-2026-12491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12491
- OSV: https://osv.dev/vulnerability/CVE-2026-12491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12491/
Summaries are generated and may contain mistakes; the official description above is the record.
