# CVE-2026-12515: Katello: missing repository authorization in content_uploads exposes cross-product content existence

> Authenticated attackers with edit_products permission can query content existence in unauthorized repositories, leaking information about inaccessible content.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-c43c-rf7g-5xpg

## What is CVE-2026-12515?

CVE-2026-12515 is a medium-severity missing authorization vulnerability in Red Hat Hardened Images, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Katello's of Red Hat Satellite. A content upload functionality where insufficient authorization checks in the ContentUploadsController allowed users with the edit_products permission to query content information for repositories outside the products they were authorized to manage. An authenticated attacker could exploit this issue to determine whether specific content exists within repositories that should otherwise be inaccessible. This issue does not allow unauthorized modification, import, or publication of content.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-12515?

2 open source packages ship an affected version, including katello.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katello` | RubyGems | All versions | 4.21.0.rc1 |
| `katello` | RubyGems | All versions | 4.21.0.rc1 |

## How do I fix CVE-2026-12515?

Upgrade katello to 4.21.0.rc1 or later.

## Is CVE-2026-12515 being exploited?

There is no known exploitation of CVE-2026-12515 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12515 and fix it if it is affected.

What it is: CVE-2026-12515 is a medium-severity missing authorization vulnerability in Red Hat Hardened Images, published on 17 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-12515 in the wild and no public exploit code.

Affected packages and fixed versions:
- katello (RubyGems): affected all versions; fixed in 4.21.0.rc1
- katello (RubyGems): affected all versions; fixed in 4.21.0.rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12515/ (Markdown: https://insights.sbomify.com/CVE-2026-12515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12515
- OSV: https://osv.dev/vulnerability/CVE-2026-12515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12515/
Summaries are generated and may contain mistakes; the official description above is the record.
