CVE-2026-12537 Unauthenticated Remote Code Execution in Gemini CLI CI/CD Workflows
An unauthenticated attacker can execute arbitrary code on the host by exploiting improper neutralization in the container launcher via a malicious .env file.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-12537?
CVE-2026-12537 is a critical command injection vulnerability in Google Cloud Gemini CLI, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization used in an OS Command in the container launcher in Google Gemini CLI (versions prior to 0.39.1) and run-gemini-cli GitHub Action (versions prior to 0.1.22) on headless CI platforms allows an unprivileged attacker to achieve pre-sandbox host-level code execution a maliciously crafted .gemini/.env file.
Which versions are affected by CVE-2026-12537?
5 open source packages ship an affected version, including @google/gemini-cli and google-github-actions/run-gemini-cli. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@google/gemini-cli npm | All versions | 0.39.1 |
@google/gemini-cli npm | All versions | 0.39.1 |
@google/gemini-cli npm | From 0.40.0-preview.2 | 0.40.0-preview.3 |
@google/gemini-cli npm | From 0.40.0-preview.2 | 0.40.0-preview.3 |
google-github-actions/run-gemini-cli GitHub Actions | All versions | 0.1.22 |
Products include Google Gemini-Cli, Google Run-Gemini-Cli.
How do I fix CVE-2026-12537?
Upgrade @google/gemini-cli to a fixed version for your release line: 0.39.1 or 0.40.0-preview.3.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-12537 being exploited?
There is no known exploitation of CVE-2026-12537 in the wild and no public exploit code.
Sources
Also known as GHSA-wpqr-6v78-jr5g, MINI-78jg-xhr8-46rq.