{"answers":{"affected":"3 open source packages ship an affected version, including bbot.","exploited":"There is no known exploitation of CVE-2026-12565 in the wild and no public exploit code.","fix":"Upgrade bbot to 2.8.5 or later.","what":"CVE-2026-12565 is a medium-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-12565 and fix it if it is affected.\n\nWhat it is: CVE-2026-12565 is a medium-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-12565 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bbot (PyPI): affected from 2.3.1; fixed in 2.8.5\n- bbot (PyPI): affected from 2.3.1; fixed in 2.8.5\n- bbot (PyPI): affected from 2.3.1; fixed in 2.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-12565/ (Markdown: https://insights.sbomify.com/CVE-2026-12565/index.md)","id":"CVE-2026-12565","markdown":"https://insights.sbomify.com/CVE-2026-12565/index.md","name":"CVE-2026-12565","record":{"aliases":["GHSA-3vgw-585j-4m45","PYSEC-2026-2392"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"BBOT security tool","requires_auth":"none","summary":"Attackers can exploit path traversal in BBOT's unarchive module to write files outside the extraction directory, potentially leading to code execution on systems with older tar versions.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"BLSOPS","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The unarchive internal module's archive extraction commands perform no code-level validation on extracted file paths, relying entirely on the behavior of external tools (e.g. GNU tar) which varies by platform. While CVE-2025-10284 addressed git-specific RCE vectors, the underlying archive extraction path traversal was never fixed. On systems with GNU tar \u003c 1.34 (Ubuntu 20.04, Debian Buster, CentOS 7, many Docker base images), a malicious archive can write files outside the intended extraction directory.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal (Zip-Slip) in unarchive module","id":"CVE-2026-12565","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"SSRF via unvalidated WWW-Authenticate realm in docker_pull module","id":"CVE-2026-12566"},"packages":[{"ecosystem":"PyPI","fixed":["2.8.5"],"introduced":["2.3.1"],"last_affected":[],"package":"bbot","purl":null,"source":"GHSA-3vgw-585j-4m45"},{"ecosystem":"PyPI","fixed":["2.8.5"],"introduced":["2.3.1"],"last_affected":[],"package":"bbot","purl":"pkg:pypi/bbot","source":"GHSA-3vgw-585j-4m45"},{"ecosystem":"PyPI","fixed":["2.8.5"],"introduced":["2.3.1"],"last_affected":[],"package":"bbot","purl":"pkg:pypi/bbot","source":"PYSEC-2026-2392"}],"prev":{"headline":"Server-side request forgery in Red Hat Ansible Automation Platform 2.4 for RHEL 8","id":"CVE-2026-12564"},"products":["BBOT"],"published":"2026-06-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-18","vendors":["Black Lantern Security"]},"summary":"Attackers can exploit path traversal in BBOT's unarchive module to write files outside the extraction directory, potentially leading to code execution on systems with older tar versions.","url":"https://insights.sbomify.com/CVE-2026-12565/"}