# CVE-2026-12566: SSRF via unvalidated WWW-Authenticate realm in docker_pull module

> A man-in-the-middle attacker can redirect authentication requests to arbitrary endpoints via unvalidated realm headers, potentially leaking tokens.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-3mp7-vp6j-2mxx, PYSEC-2026-2391

## What is CVE-2026-12566?

CVE-2026-12566 is a low-severity server-side request forgery vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The docker_pull module uses the realm parameter from a Docker registry's WWW-Authenticate response header as the authentication endpoint without validation. An attacker in a man-in-the-middle position between bbot and a Docker registry could modify this header to redirect the authentication request to an arbitrary endpoint, potentially leaking authentication tokens.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-12566?

3 open source packages ship an affected version, including bbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |

## How do I fix CVE-2026-12566?

Upgrade bbot to 2.8.5 or later.

## Is CVE-2026-12566 being exploited?

There is no known exploitation of CVE-2026-12566 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12566 and fix it if it is affected.

What it is: CVE-2026-12566 is a low-severity server-side request forgery vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-12566 in the wild and no public exploit code.

Affected packages and fixed versions:
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12566/ (Markdown: https://insights.sbomify.com/CVE-2026-12566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12566
- OSV: https://osv.dev/vulnerability/CVE-2026-12566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12566/
Summaries are generated and may contain mistakes; the official description above is the record.
