# CVE-2026-12567: Symlink-following arbitrary write via github_workflows module

> A local attacker can exploit symlink handling in BBOT's github_workflows module to write arbitrary files to sensitive locations.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-rvp7-w75q-9fv2, PYSEC-2026-2394

## What is CVE-2026-12567?

CVE-2026-12567 is a low-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The github_workflows module constructs local directory paths from user-controlled repository names without validating for symlinks. A local attacker sharing the scan directory can plant a symlink at the predictable output path, causing workflow data to be written to an attacker-chosen location.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-12567?

3 open source packages ship an affected version, including bbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |
| `bbot` | PyPI | From 2.0.0 | 2.8.5 |

## How do I fix CVE-2026-12567?

Upgrade bbot to 2.8.5 or later.

## Is CVE-2026-12567 being exploited?

There is no known exploitation of CVE-2026-12567 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12567 and fix it if it is affected.

What it is: CVE-2026-12567 is a low-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-12567 in the wild and no public exploit code.

Affected packages and fixed versions:
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5
- bbot (PyPI): affected from 2.0.0; fixed in 2.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12567/ (Markdown: https://insights.sbomify.com/CVE-2026-12567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12567
- OSV: https://osv.dev/vulnerability/CVE-2026-12567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12567/
Summaries are generated and may contain mistakes; the official description above is the record.
