# CVE-2026-12568: Arbitrary File Write in postman_download module

> Attackers can write arbitrary files to the user's system via path traversal in the postman_download module of BBOT.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-m54h-vhf9-3w3m, PYSEC-2026-2393

## What is CVE-2026-12568?

CVE-2026-12568 is a medium-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The postman_download module uses the workspace name field from the Postman API to construct the local directory path without sanitization. If a malicious workspace has a name containing path traversal characters, pathlib resolves the path outside the intended output directory, allowing an attacker to write arbitrary files to the user's system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-12568?

3 open source packages ship an affected version, including bbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bbot` | PyPI | From 2.1.0 | 2.8.6 |
| `bbot` | PyPI | From 2.1.0 | 2.8.6 |
| `bbot` | PyPI | From 2.1.0 | 2.8.6 |

## How do I fix CVE-2026-12568?

Upgrade bbot to 2.8.6 or later.

## Is CVE-2026-12568 being exploited?

There is no known exploitation of CVE-2026-12568 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12568 and fix it if it is affected.

What it is: CVE-2026-12568 is a medium-severity path traversal vulnerability in Black Lantern Security BBOT, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-12568 in the wild and no public exploit code.

Affected packages and fixed versions:
- bbot (PyPI): affected from 2.1.0; fixed in 2.8.6
- bbot (PyPI): affected from 2.1.0; fixed in 2.8.6
- bbot (PyPI): affected from 2.1.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12568/ (Markdown: https://insights.sbomify.com/CVE-2026-12568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12568
- OSV: https://osv.dev/vulnerability/CVE-2026-12568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12568/
Summaries are generated and may contain mistakes; the official description above is the record.
