CVE-2026-12590 body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement
An attacker can cause denial of service by sending oversized payloads if the body-parser limit is misconfigured with an invalid value, bypassing size checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-12590?
CVE-2026-12590 is a low-severity denial of service vulnerability in body-parser, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact: In body-parser versions prior to 1.20.6 (1.x line) and 2.3.0 (2.x line), when the parser is configured with an invalid limit option value such as an unparseable string or NaN, bytes.parse returns null and the request body size check is silently skipped. Applications that rely on limit as their primary safeguard against oversized request bodies will accept arbitrarily large payloads, leading to excessive memory and CPU usage and denial of service. Patches: This issue is fixed in body-parser 1.20.6 and 2.3.0. After the fix, invalid limit values throw a clear error at parser construction time instead of silently disabling enforcement, while null and undefined continue to fall back to the default limit of 100kb. Workarounds: Validate the limit value before passing it to body-parser. For example, parse the value at startup and reject any configuration where the result is null or a non-finite number.
Weakness: CWE-770
Which versions are affected by CVE-2026-12590?
4 open source packages ship an affected version, including body-parser. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
body-parser npm | All versions | 1.20.6 |
body-parser npm | All versions | 1.20.6 |
body-parser npm | From 2.0.0 | 2.3.0 |
body-parser npm | From 2.0.0 | 2.3.0 |
Products include Openjsf Body-Parser.
How do I fix CVE-2026-12590?
Upgrade body-parser to a fixed version for your release line: 1.20.6 or 2.3.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-12590 being exploited?
There is no known exploitation of CVE-2026-12590 in the wild and no public exploit code.
Other vulnerabilities in body-parser
Sources
Also known as CLEANSTART-2026-LL95824, CLEANSTART-2026-NW68824, CLEANSTART-2026-VN12765, CLSA-2026-1784596302, CLSA-2026-1787151610, CLSA-2026-1787151617 and 36 more.