# CVE-2026-12590: body-parser vulnerable to denial of service when invalid limit value silently disables size enforcement

> An attacker can cause denial of service by sending oversized payloads if the body-parser limit is misconfigured with an invalid value, bypassing size checks.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** CLEANSTART-2026-LL95824, CLEANSTART-2026-NW68824, CLEANSTART-2026-VN12765, CLSA-2026-1784596302, CLSA-2026-1787151610, CLSA-2026-1787151617, CLSA-2026-1787151664, CLSA-2026-1787151794, CLSA-2026-1787256348, CLSA-2026-1787256578, CLSA-2026-1790520930, CLSA-2026-1790541942, CLSA-2026-1790544295, CLSA-2026-1792476566, DEBIAN-CVE-2026-12590, ECHO-3694-8cb9-895a, GHSA-v422-hmwv-36x6, MINI-3v3f-38v7-2656, MINI-4c52-hh36-hwxr, MINI-55ww-jjjj-98q7, MINI-562m-r57q-wfmr, MINI-65p2-96mq-x2mg, MINI-72f3-254f-5x29, MINI-78fj-q6wf-v6rv, MINI-7j3c-hvjw-7v59, MINI-7q63-cj62-2344, MINI-838j-929g-v996, MINI-94hv-fpcr-q23p, MINI-95mp-8658-82cj, MINI-9gfr-9rrw-5373, MINI-f9xc-pm76-v87g, MINI-ffmf-7f46-cf22, MINI-gxwq-543h-39cf, MINI-m28j-whg8-4hxc, MINI-m2fp-rw3g-v654, MINI-qvfp-qghc-8gq4, MINI-rq8q-69m6-m2vq, MINI-v3fg-6263-qh2c, MINI-x4j2-j4q5-q7x8, MINI-xvwh-gj88-4h6p, ROOT-APP-NPM-CVE-2026-12590, UBUNTU-CVE-2026-12590

## What is CVE-2026-12590?

CVE-2026-12590 is a low-severity denial of service vulnerability in body-parser, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: In body-parser versions prior to 1.20.6 (1.x line) and 2.3.0 (2.x line), when the parser is configured with an invalid limit option value such as an unparseable string or NaN, bytes.parse returns null and the request body size check is silently skipped. Applications that rely on limit as their primary safeguard against oversized request bodies will accept arbitrarily large payloads, leading to excessive memory and CPU usage and denial of service. Patches: This issue is fixed in body-parser 1.20.6 and 2.3.0. After the fix, invalid limit values throw a clear error at parser construction time instead of silently disabling enforcement, while null and undefined continue to fall back to the default limit of 100kb. Workarounds: Validate the limit value before passing it to body-parser. For example, parse the value at startup and reject any configuration where the result is null or a non-finite number.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-12590?

4 open source packages ship an affected version, including body-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `body-parser` | npm | All versions | 1.20.6 |
| `body-parser` | npm | All versions | 1.20.6 |
| `body-parser` | npm | From 2.0.0 | 2.3.0 |
| `body-parser` | npm | From 2.0.0 | 2.3.0 |

Products: Openjsf Body-Parser.

## How do I fix CVE-2026-12590?

Upgrade body-parser to a fixed version for your release line: 1.20.6 or 2.3.0.

## Is CVE-2026-12590 being exploited?

There is no known exploitation of CVE-2026-12590 in the wild and no public exploit code.

## Other vulnerabilities in body-parser

- [CVE-2024-45590](https://insights.sbomify.com/CVE-2024-45590/): body-parser vulnerable to denial of service when url encoding is enabled (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12590 and fix it if it is affected.

What it is: CVE-2026-12590 is a low-severity denial of service vulnerability in body-parser, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-12590 in the wild and no public exploit code.

Affected packages and fixed versions:
- body-parser (npm): affected all versions; fixed in 1.20.6
- body-parser (npm): affected all versions; fixed in 1.20.6
- body-parser (npm): affected from 2.0.0; fixed in 2.3.0
- body-parser (npm): affected from 2.0.0; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12590/ (Markdown: https://insights.sbomify.com/CVE-2026-12590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12590
- OSV: https://osv.dev/vulnerability/CVE-2026-12590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12590/
Summaries are generated and may contain mistakes; the official description above is the record.
