{"answers":{"affected":"3 open source packages ship an affected version, including sentencepiece. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-1260 in the wild and no public exploit code.","fix":"Upgrade sentencepiece to 0.2.1 or later.","what":"CVE-2026-1260 is a high-severity memory corruption vulnerability in Google Sentencepiece, published on 22 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-1260 and fix it if it is affected.\n\nWhat it is: CVE-2026-1260 is a high-severity memory corruption vulnerability in Google Sentencepiece, published on 22 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-1260 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentencepiece (PyPI): affected all versions; fixed in 0.2.1\n- sentencepiece (PyPI): affected all versions; fixed in 0.2.1\n- sentencepiece (PyPI): affected all versions; fixed in 0.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1260/ (Markdown: https://insights.sbomify.com/CVE-2026-1260/index.md)","id":"CVE-2026-1260","markdown":"https://insights.sbomify.com/CVE-2026-1260/index.md","name":"CVE-2026-1260","record":{"aliases":["GHSA-38vq-g6vr-w8wf","OESA-2026-3915","OESA-2026-3916","OESA-2026-3917","OESA-2026-4045","PYSEC-2026-1909"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Sentencepiece library","requires_auth":"none","summary":"Attackers can trigger invalid memory access and potential code execution by providing a specially crafted model file to the Sentencepiece library.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"sentencepiece","vendor":"google"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Invalid memory access in Sentencepiece versions less than 0.2.1 when using a vulnerable model file, which is not created in the normal training procedure.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Invalid Memory Access in Sentencepiece,","id":"CVE-2026-1260","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"MetForm Pro \u003c= 3.9.6 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2026-1261"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"sentencepiece","purl":null,"source":"GHSA-38vq-g6vr-w8wf"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"sentencepiece","purl":"pkg:pypi/sentencepiece","source":"GHSA-38vq-g6vr-w8wf"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"sentencepiece","purl":"pkg:pypi/sentencepiece","source":"PYSEC-2026-1909"}],"prev":{"headline":"Mail Mint \u003c= 1.19.2 - Authenticated (Administrator+) SQL Injection via Multiple API Endpoints","id":"CVE-2026-1258"},"products":["Sentencepiece"],"published":"2026-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["Google"]},"summary":"Attackers can trigger invalid memory access and potential code execution by providing a specially crafted model file to the Sentencepiece library.","url":"https://insights.sbomify.com/CVE-2026-1260/"}