# CVE-2026-12624: Vault vulnerable to LIST authorization bypass via trailing-slash strip

> Attackers can bypass ACL deny rules to enumerate secret names via trailing slashes, exposing sensitive metadata in HashiCorp Vault deployments.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2026
- **Updated:** 11 Aug 2026
- **Also known as:** BIT-vault-2026-12624, MINI-7ggp-cf69-qc79

## What is CVE-2026-12624?

CVE-2026-12624 is a medium-severity missing authorization vulnerability in HashiCorp Vault, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vault’s ACL policy engine did not consistently enforce a wildcard (glob) deny rule against LIST requests made with a trailing slash on the denied path. This may allow a token holding a broader allow rule alongside a narrower wildcard deny rule to enumerate the names of entries beneath a path it was intended to be denied access to. This vulnerability (CVE-2026-12624) is fixed in Vault Community Edition 2.0.3 and Vault Enterprise 2.0.3, 1.21.8, 1.20.13, and 1.19.19.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-12624?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | All versions | 2.0.3 |

## How do I fix CVE-2026-12624?

Upgrade vault to 2.0.3 or later.

## Is CVE-2026-12624 being exploited?

There is no known exploitation of CVE-2026-12624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12624 and fix it if it is affected.

What it is: CVE-2026-12624 is a medium-severity missing authorization vulnerability in HashiCorp Vault, published on 10 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-12624 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12624/ (Markdown: https://insights.sbomify.com/CVE-2026-12624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12624
- OSV: https://osv.dev/vulnerability/CVE-2026-12624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12624/
Summaries are generated and may contain mistakes; the official description above is the record.
