CVE-2026-12664 Incorrect Authorization in GitLab
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-12664?
CVE-2026-12664 is a medium-severity vulnerability in Gitlab Gitlab, published on 21 Oct 2026.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an authenticated user with a read_api-scoped token to retrieve a project's incoming email address and create work items, bypassing the token's restrictions, due to insufficient scope enforcement on a GraphQL field.
Weakness: CWE-863
Which versions are affected by CVE-2026-12664?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 18.2.0 | 19.3.6, 19.4.3, 19.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-12664?
Upgrade gitlab to a fixed version for your release line: 19.3.6, 19.4.3 or 19.5.1.
Is CVE-2026-12664 being exploited?
There is no known exploitation of CVE-2026-12664 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2026-12664, GHSA-g33c-grwm-jpgc.