# CVE-2026-12664: Incorrect Authorization in GitLab


- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** BIT-gitlab-2026-12664, GHSA-g33c-grwm-jpgc

## What is CVE-2026-12664?

CVE-2026-12664 is a medium-severity vulnerability in Gitlab Gitlab, published on 21 Oct 2026. 

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an authenticated user with a read_api-scoped token to retrieve a project's incoming email address and create work items, bypassing the token's restrictions, due to insufficient scope enforcement on a GraphQL field.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-12664?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 18.2.0 | 19.3.6, 19.4.3, 19.5.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-12664?

Upgrade gitlab to a fixed version for your release line: 19.3.6, 19.4.3 or 19.5.1.

## Is CVE-2026-12664 being exploited?

There is no known exploitation of CVE-2026-12664 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12664 and fix it if it is affected.

What it is: CVE-2026-12664 is a medium-severity vulnerability in Gitlab Gitlab, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-12664 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 18.2.0; fixed in 19.3.6, 19.4.3, 19.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12664/ (Markdown: https://insights.sbomify.com/CVE-2026-12664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12664
- OSV: https://osv.dev/vulnerability/CVE-2026-12664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12664/
Summaries are generated and may contain mistakes; the official description above is the record.
