# CVE-2026-12773: BerriAI litellm MCP Proxy user_api_key_auth_mcp.py UserAPIKeyAuth improper authentication

> Remote attackers can bypass authentication in the LiteLLM MCP Proxy component, gaining unauthorized access to protected resources.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ECHO-ec81-be0d-b655, GHSA-4jcj-7x88-m979, MINI-4mq8-j5px-v3wj, MINI-972q-gh6p-7f99, PYSEC-2026-4067

## What is CVE-2026-12773?

CVE-2026-12773 is a medium-severity authentication bypass vulnerability in BerriAI litellm, published on 21 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-12773?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-12773?

Upgrade litellm to 1.84.0 or later.

## Is CVE-2026-12773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12773 exists.

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12773 and fix it if it is affected.

What it is: CVE-2026-12773 is a medium-severity authentication bypass vulnerability in BerriAI litellm, published on 21 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12773 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12773/ (Markdown: https://insights.sbomify.com/CVE-2026-12773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12773
- OSV: https://osv.dev/vulnerability/CVE-2026-12773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12773/
Summaries are generated and may contain mistakes; the official description above is the record.
