CVE-2026-1285 Potential denial-of-service vulnerability in django.utils.text.Truncator HTML methods
Remote attackers can cause denial of service in Django applications using HTML truncation features by submitting crafted inputs with many unmatched HTML end tags.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-1285?
CVE-2026-1285 is a high-severity denial of service vulnerability in Djangoproject Django, published on 3 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. `django.utils.text.Truncator.chars()` and `Truncator.words()` methods (with `html=True`) and the `truncatechars_html` and `truncatewords_html` template filters allow a remote attacker to cause a potential denial-of-service via crafted inputs containing a large number of unmatched HTML end tags. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.
Weakness: CWE-407
Which versions are affected by CVE-2026-1285?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 4.2.28, 5.2.11, 6.0.2 |
django PyPI | From 4.2 | 4.2.28, 5.2.11, 6.0.2 |
django PyPI | From 4.2a1 | 4.2.28 |
django PyPI | From 5.2a1 | 5.2.11 |
django PyPI | From 6.0a1 | 6.0.2 |
Django PyPI | From 4.2a1 | 4.2.28 |
2 more packages
Django PyPI | From 5.2a1 | 5.2.11 |
Django PyPI | From 6.0a1 | 6.0.2 |
Products include Djangoproject Django.
How do I fix CVE-2026-1285?
Upgrade django to a fixed version for your release line: 4.2.28, 5.2.11 or 6.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-1285 being exploited?
There is no known exploitation of CVE-2026-1285 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2026-1285, CLSA-2026-1789128267, CLSA-2026-1791273474, DEBIAN-CVE-2026-1285, ECHO-f509-4388-9b59, GHSA-4rrr-2h4v-f3j9 and 2 more.