# CVE-2026-1287: Potential SQL injection in column aliases via control characters

> Attackers can execute SQL injection via control characters in column aliases using FilteredRelation, requiring an upgrade to patched Django versions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-django-2026-1287, CLSA-2026-1788334218, DEBIAN-CVE-2026-1287, ECHO-f04c-582a-df62, GHSA-gvg8-93h5-g6qq, MINI-6wr8-cwj9-hr4w, PYSEC-2026-46, UBUNTU-CVE-2026-1287, USN-8009-1

## What is CVE-2026-1287?

CVE-2026-1287 is a medium-severity SQL injection vulnerability in Djangoproject Django, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28.
`FilteredRelation` is subject to SQL injection in column aliases via control characters, using a suitably crafted dictionary, with dictionary expansion, as the `**kwargs` passed to `QuerySet` methods `annotate()`, `aggregate()`, `extra()`, `values()`, `values_list()`, and `alias()`.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Solomon Kebede for reporting this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-1287?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.28, 5.2.11, 6.0.2 |
| `django` | PyPI | From 4.2 | 4.2.28, 5.2.11, 6.0.2 |
| `django` | PyPI | From 4.2a1 | 4.2.28 |
| `django` | PyPI | From 5.2a1 | 5.2.11 |
| `django` | PyPI | From 6.0a1 | 6.0.2 |
| `Django` | PyPI | From 4.2a1 | 4.2.28 |
| `Django` | PyPI | From 5.2a1 | 5.2.11 |
| `Django` | PyPI | From 6.0a1 | 6.0.2 |

Products: Djangoproject Django.

## How do I fix CVE-2026-1287?

Upgrade django to a fixed version for your release line: 4.2.28, 5.2.11 or 6.0.2.

## Is CVE-2026-1287 being exploited?

There is no known exploitation of CVE-2026-1287 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1287 and fix it if it is affected.

What it is: CVE-2026-1287 is a medium-severity SQL injection vulnerability in Djangoproject Django, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1287 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.28, 5.2.11, 6.0.2
- django (PyPI): affected from 4.2; fixed in 4.2.28, 5.2.11, 6.0.2
- django (PyPI): affected from 4.2a1; fixed in 4.2.28
- django (PyPI): affected from 5.2a1; fixed in 5.2.11
- django (PyPI): affected from 6.0a1; fixed in 6.0.2
- Django (PyPI): affected from 4.2a1; fixed in 4.2.28
- Django (PyPI): affected from 5.2a1; fixed in 5.2.11
- Django (PyPI): affected from 6.0a1; fixed in 6.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1287/ (Markdown: https://insights.sbomify.com/CVE-2026-1287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1287
- OSV: https://osv.dev/vulnerability/CVE-2026-1287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1287/
Summaries are generated and may contain mistakes; the official description above is the record.
