CVE-2026-12957 Arbitrary Code Execution in Language Servers for AWS

High 8.5 Published Updated

A local attacker can execute arbitrary code by tricking a user into opening a malicious workspace in AWS Language Servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-12957?

CVE-2026-12957 is a high-severity code injection vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted.

To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

Weakness: CWE-732

Which versions are affected by CVE-2026-12957?

2 open source packages ship an affected version, including @aws/lsp-codewhisperer.

PackageAffectedFixed in
@aws/lsp-codewhisperer npmAll versions0.0.113
@aws/lsp-codewhisperer npmAll versions0.0.113

How do I fix CVE-2026-12957?

Upgrade @aws/lsp-codewhisperer to 0.0.113 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-12957 being exploited?

There is no known exploitation of CVE-2026-12957 in the wild and no public exploit code.

Sources

Also known as GHSA-xhcr-j4j9-3gh7.

Is CVE-2026-12957 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free