{"answers":{"affected":"2 open source packages ship an affected version, including @aws/lsp-codewhisperer.","exploited":"There is no known exploitation of CVE-2026-12957 in the wild and no public exploit code.","fix":"Upgrade @aws/lsp-codewhisperer to 0.0.113 or later.","what":"CVE-2026-12957 is a high-severity code injection vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-12957 and fix it if it is affected.\n\nWhat it is: CVE-2026-12957 is a high-severity code injection vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-12957 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.113\n- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.113\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-12957/ (Markdown: https://insights.sbomify.com/CVE-2026-12957/index.md)","id":"CVE-2026-12957","markdown":"https://insights.sbomify.com/CVE-2026-12957/index.md","name":"CVE-2026-12957","record":{"aliases":["GHSA-xhcr-j4j9-3gh7"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS Language Server","requires_auth":"none","summary":"A local attacker can execute arbitrary code by tricking a user into opening a malicious workspace in AWS Language Servers.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted.\n\nTo remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Code Execution in Language Servers for AWS","id":"CVE-2026-12957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary file write in Language Servers for AWS","id":"CVE-2026-12958"},"packages":[{"ecosystem":"npm","fixed":["0.0.113"],"introduced":["0"],"last_affected":[],"package":"@aws/lsp-codewhisperer","purl":null,"source":"GHSA-xhcr-j4j9-3gh7"},{"ecosystem":"npm","fixed":["0.0.113"],"introduced":["0"],"last_affected":[],"package":"@aws/lsp-codewhisperer","purl":"pkg:npm/%40aws/lsp-codewhisperer","source":"GHSA-xhcr-j4j9-3gh7"}],"prev":{"headline":"Missing authorization in Eventin – Event Calendar, Tickets, Registration, Booking \u0026 WooCommerce","id":"CVE-2026-12956"},"products":["Language Servers for AWS"],"published":"2026-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["Amazon Web Services"]},"summary":"A local attacker can execute arbitrary code by tricking a user into opening a malicious workspace in AWS Language Servers.","url":"https://insights.sbomify.com/CVE-2026-12957/"}