CVE-2026-12958 Arbitrary file write in Language Servers for AWS

High 8.5 Published Updated

Attackers can write arbitrary files outside the workspace via malicious symlinks, requiring users to upgrade the AWS Language Servers extension.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-12958?

CVE-2026-12958 is a high-severity path traversal vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary.

To remediate this issue, users should upgrade to version 1.69.0 or higher.

Weakness: CWE-61

Which versions are affected by CVE-2026-12958?

2 open source packages ship an affected version, including @aws/lsp-codewhisperer.

PackageAffectedFixed in
@aws/lsp-codewhisperer npmAll versions0.0.117
@aws/lsp-codewhisperer npmAll versions0.0.117

How do I fix CVE-2026-12958?

Upgrade @aws/lsp-codewhisperer to 0.0.117 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-12958 being exploited?

There is no known exploitation of CVE-2026-12958 in the wild and no public exploit code.

Sources

Also known as GHSA-6v3r-4p5c-mrp5.

Is CVE-2026-12958 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free