{"answers":{"affected":"2 open source packages ship an affected version, including @aws/lsp-codewhisperer.","exploited":"There is no known exploitation of CVE-2026-12958 in the wild and no public exploit code.","fix":"Upgrade @aws/lsp-codewhisperer to 0.0.117 or later.","what":"CVE-2026-12958 is a high-severity path traversal vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-12958 and fix it if it is affected.\n\nWhat it is: CVE-2026-12958 is a high-severity path traversal vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-12958 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.117\n- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.117\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-12958/ (Markdown: https://insights.sbomify.com/CVE-2026-12958/index.md)","id":"CVE-2026-12958","markdown":"https://insights.sbomify.com/CVE-2026-12958/index.md","name":"CVE-2026-12958","record":{"aliases":["GHSA-6v3r-4p5c-mrp5"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS Language Servers","requires_auth":"none","summary":"Attackers can write arbitrary files outside the workspace via malicious symlinks, requiring users to upgrade the AWS Language Servers extension.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary.\n\nTo remediate this issue, users should upgrade to version 1.69.0 or higher.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary file write in Language Servers for AWS","id":"CVE-2026-12958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Other in Router app","id":"CVE-2026-12960"},"packages":[{"ecosystem":"npm","fixed":["0.0.117"],"introduced":["0"],"last_affected":[],"package":"@aws/lsp-codewhisperer","purl":null,"source":"GHSA-6v3r-4p5c-mrp5"},{"ecosystem":"npm","fixed":["0.0.117"],"introduced":["0"],"last_affected":[],"package":"@aws/lsp-codewhisperer","purl":"pkg:npm/%40aws/lsp-codewhisperer","source":"GHSA-6v3r-4p5c-mrp5"}],"prev":{"headline":"Arbitrary Code Execution in Language Servers for AWS","id":"CVE-2026-12957"},"products":["Language Servers for AWS"],"published":"2026-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["Amazon Web Services"]},"summary":"Attackers can write arbitrary files outside the workspace via malicious symlinks, requiring users to upgrade the AWS Language Servers extension.","url":"https://insights.sbomify.com/CVE-2026-12958/"}