# CVE-2026-12958: Arbitrary file write in Language Servers for AWS

> Attackers can write arbitrary files outside the workspace via malicious symlinks, requiring users to upgrade the AWS Language Servers extension.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-6v3r-4p5c-mrp5

## What is CVE-2026-12958?

CVE-2026-12958 is a high-severity path traversal vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary.

To remediate this issue, users should upgrade to version 1.69.0 or higher.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2026-12958?

2 open source packages ship an affected version, including @aws/lsp-codewhisperer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@aws/lsp-codewhisperer` | npm | All versions | 0.0.117 |
| `@aws/lsp-codewhisperer` | npm | All versions | 0.0.117 |

## How do I fix CVE-2026-12958?

Upgrade @aws/lsp-codewhisperer to 0.0.117 or later.

## Is CVE-2026-12958 being exploited?

There is no known exploitation of CVE-2026-12958 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12958 and fix it if it is affected.

What it is: CVE-2026-12958 is a high-severity path traversal vulnerability in Amazon Web Services Language Servers for AWS, published on 23 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-12958 in the wild and no public exploit code.

Affected packages and fixed versions:
- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.117
- @aws/lsp-codewhisperer (npm): affected all versions; fixed in 0.0.117

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12958/ (Markdown: https://insights.sbomify.com/CVE-2026-12958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12958
- OSV: https://osv.dev/vulnerability/CVE-2026-12958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12958/
Summaries are generated and may contain mistakes; the official description above is the record.
