CVE-2026-13149 brace-expansion: DoS via exponential-time expansion of consecutive non-expanding {} groups
An attacker can cause denial of service by passing crafted strings to the expand function, leading to excessive CPU consumption and event-loop blocking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-13149?
CVE-2026-13149 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
brace-expansion through 5.0.6 is vulnerable to denial of service. The expand() function exhibits exponential-time complexity in the number of consecutive non-expanding '{}' brace groups. An attacker who passes a crafted string to expand(), directly or transitively, can cause significant CPU consumption and event-loop blocking. The max option does not mitigate this, as it bounds the output size rather than the recursion work.
Which versions are affected by CVE-2026-13149?
6 open source packages ship an affected version, including brace-expansion.
| Package | Affected | Fixed in |
|---|---|---|
brace-expansion npm | All versions | 1.1.16 |
brace-expansion npm | All versions | 1.1.16 |
brace-expansion npm | From 2.0.0 | 2.1.2 |
brace-expansion npm | From 2.0.0 | 2.1.2 |
brace-expansion npm | From 3.0.0 | 5.0.7 |
brace-expansion npm | From 3.0.0 | 5.0.7 |
Linux distribution packages (5)
nodejs-nodemon AlmaLinux:10 | All versions | 3.1.14-2.el10_2 |
nodejs-nodemon Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.14-2.el10_2 |
nodejs-nodemon Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.1.14-2.el10_0 |
nodejs-nodemon Rocky Linux:10 | All versions | 0:3.1.14-2.el10_2 |
python-pytest-html openSUSE:Leap 16.0 | All versions | 4.1.1-bp160.4.1 |
How do I fix CVE-2026-13149?
Upgrade brace-expansion to a fixed version for your release line: 1.1.16, 2.1.2 or 5.0.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-13149 being exploited?
There is no known exploitation of CVE-2026-13149 in the wild and no public exploit code.
Sources
Also known as ALSA-2026:48032, CLEANSTART-2026-EG71215, CLEANSTART-2026-FO44307, CLEANSTART-2026-SI16873, CLEANSTART-2026-UX64069, CLSA-2026-1784596285 and 50 more.