# CVE-2026-13149: brace-expansion: DoS via exponential-time expansion of consecutive non-expanding {} groups

> An attacker can cause denial of service by passing crafted strings to the expand function, leading to excessive CPU consumption and event-loop blocking.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/S:N/AU:Y/R:U/V:D/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 8 Jul 2026
- **Also known as:** ALSA-2026:48032, CLEANSTART-2026-EG71215, CLEANSTART-2026-FO44307, CLEANSTART-2026-SI16873, CLEANSTART-2026-UX64069, CLSA-2026-1784596285, DEBIAN-CVE-2026-13149, ECHO-ae86-415b-ba40, GHSA-3jxr-9vmj-r5cp, MINI-28g9-m4vf-j27v, MINI-29w3-39wj-2pph, MINI-2x57-mf9f-89v4, MINI-349p-xxpp-xp8j, MINI-3mfh-59mq-9xc9, MINI-6996-wxf8-m5mx, MINI-6pfq-8cgc-36xm, MINI-6pj2-2wvh-v6pq, MINI-7fx2-gjq3-57f9, MINI-7m8w-q8mq-5fvg, MINI-83xf-pm9r-vmgm, MINI-83xh-wp47-vxv6, MINI-8f63-43v9-ph48, MINI-8qvp-9gx7-fp2p, MINI-9c43-7v6m-85g7, MINI-9vhh-hpf2-3gfm, MINI-9vv8-9vpq-2wrg, MINI-c332-jrhp-r83f, MINI-cfmr-4wf2-5gxh, MINI-f65v-v6rq-3r2f, MINI-f7vr-qggw-mw6c, MINI-f9f2-233f-xw4x, MINI-g27r-c53v-2c4p, MINI-gh95-cmvc-4h36, MINI-hch6-9x7g-mpmw, MINI-hf74-4qqq-5ph9, MINI-hf7v-x976-8qpq, MINI-j4p8-748v-7qvw, MINI-jch7-wjr2-mpw3, MINI-mjrq-25h6-w7w4, MINI-pv2f-5wqc-9pwv, MINI-r4r6-vg9h-243h, MINI-r9q3-j232-8cg3, MINI-vhvh-8f2f-m966, MINI-vw6j-cg2j-w8r9, MINI-w4r6-4p63-8cg8, MINI-w785-6prw-wph5, MINI-x4p4-3q67-w4qv, MINI-xg63-wqm5-qcw5, MINI-xhr5-f2q7-pgfw, MINI-xj37-pxh5-r8hr, RHSA-2026:48032, RHSA-2026:52394, RLSA-2026:48032, ROOT-APP-NPM-CVE-2026-13149, UBUNTU-CVE-2026-13149, openSUSE-SU-2026:21312-1

## What is CVE-2026-13149?

CVE-2026-13149 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

brace-expansion through 5.0.6 is vulnerable to denial of service. The expand() function exhibits exponential-time complexity in the number of consecutive non-expanding '{}' brace groups. An attacker who passes a crafted string to expand(), directly or transitively, can cause significant CPU consumption and event-loop blocking. The max option does not mitigate this, as it bounds the output size rather than the recursion work.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-13149?

6 open source packages ship an affected version, including brace-expansion.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `brace-expansion` | npm | All versions | 1.1.16 |
| `brace-expansion` | npm | All versions | 1.1.16 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.2 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.2 |
| `brace-expansion` | npm | From 3.0.0 | 5.0.7 |
| `brace-expansion` | npm | From 3.0.0 | 5.0.7 |
| `nodejs-nodemon` | AlmaLinux:10 | All versions | 3.1.14-2.el10_2 |
| `nodejs-nodemon` | Red Hat:enterprise_linux:10.2 | All versions | 0:3.1.14-2.el10_2 |
| `nodejs-nodemon` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:3.1.14-2.el10_0 |
| `nodejs-nodemon` | Rocky Linux:10 | All versions | 0:3.1.14-2.el10_2 |
| `python-pytest-html` | openSUSE:Leap 16.0 | All versions | 4.1.1-bp160.4.1 |

## How do I fix CVE-2026-13149?

Upgrade brace-expansion to a fixed version for your release line: 1.1.16, 2.1.2 or 5.0.7.

## Is CVE-2026-13149 being exploited?

There is no known exploitation of CVE-2026-13149 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-13149 and fix it if it is affected.

What it is: CVE-2026-13149 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-13149 in the wild and no public exploit code.

Affected packages and fixed versions:
- brace-expansion (npm): affected all versions; fixed in 1.1.16
- brace-expansion (npm): affected all versions; fixed in 1.1.16
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.2
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.2
- brace-expansion (npm): affected from 3.0.0; fixed in 5.0.7
- brace-expansion (npm): affected from 3.0.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-13149/ (Markdown: https://insights.sbomify.com/CVE-2026-13149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-13149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-13149
- OSV: https://osv.dev/vulnerability/CVE-2026-13149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-13149/
Summaries are generated and may contain mistakes; the official description above is the record.
