CVE-2026-1321 Membership Plugin – Restrict Content <= 3.2.20 - Unauthenticated Privilege Escalation via 'rcp_level'

High 8.1 Published Updated

Unauthenticated attackers can register with privileged membership levels to gain Administrator access due to missing validation of level status and payment requirements.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-1321?

CVE-2026-1321 is a high-severity vulnerability in stellarwp Membership Plugin – Restrict Content, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Membership Plugin – Restrict Content plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.20. This is due to the `rcp_setup_registration_init()` function accepting any membership level ID via the `rcp_level` POST parameter without validating that the level is active or that payment is required. Combined with the `add_user_role()` method which assigns the WordPress role configured on the membership level without status checks, this makes it possible for unauthenticated attackers to register with any membership level, including inactive levels that grant privileged WordPress roles such as Administrator, or paid levels that charge a sign-up fee. The vulnerability was partially patched in version 3.2.18.

Weakness: CWE-862

Which versions are affected by CVE-2026-1321?

How do I fix CVE-2026-1321?

No fix has been published for CVE-2026-1321 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-1321 being exploited?

There is no known exploitation of CVE-2026-1321 in the wild and no public exploit code.

Sources

Also known as GHSA-j7r4-m35r-qffp.

Is CVE-2026-1321 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free