{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-1321 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-1321 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-1321 is a high-severity vulnerability in stellarwp Membership Plugin – Restrict Content, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1321 and fix it if it is affected.\n\nWhat it is: CVE-2026-1321 is a high-severity vulnerability in stellarwp Membership Plugin – Restrict Content, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-1321 in the wild and no public exploit code.\n\nAffected product: stellarwp Membership Plugin – Restrict Content. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1321/ (Markdown: https://insights.sbomify.com/CVE-2026-1321/index.md)","id":"CVE-2026-1321","markdown":"https://insights.sbomify.com/CVE-2026-1321/index.md","name":"CVE-2026-1321","record":{"aliases":["GHSA-j7r4-m35r-qffp"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can register with privileged membership levels to gain Administrator access due to missing validation of level status and payment requirements.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Membership Plugin – Restrict Content plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.20. This is due to the `rcp_setup_registration_init()` function accepting any membership level ID via the `rcp_level` POST parameter without validating that the level is active or that payment is required. Combined with the `add_user_role()` method which assigns the WordPress role configured on the membership level without status checks, this makes it possible for unauthenticated attackers to register with any membership level, including inactive levels that grant privileged WordPress roles such as Administrator, or paid levels that charge a sign-up fee. The vulnerability was partially patched in version 3.2.18.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Membership Plugin – Restrict Content \u003c= 3.2.20 - Unauthenticated Privilege Escalation via 'rcp_level'","id":"CVE-2026-1321","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"Business Logic Errors in GitLab","id":"CVE-2026-1322"},"packages":[],"prev":{"headline":"Cross-site scripting in Secure Copy Content Protection and Content Locking","id":"CVE-2026-1320"},"products":["Membership Plugin – Restrict Content"],"published":"2026-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["stellarwp"]},"summary":"Unauthenticated attackers can register with privileged membership levels to gain Administrator access due to missing validation of level status and payment requirements.","url":"https://insights.sbomify.com/CVE-2026-1321/"}