CVE-2026-13210 Incorrect Authorization in GitLab

High 7.7 Published Updated

An authenticated user can access CI/CD variables outside their intended environment scope due to improper input validation in the pattern matcher.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-13210?

CVE-2026-13210 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.7 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain conditions could have allowed an authenticated user to access CI/CD variables outside their intended environment scope due to improper input validation in the environment scope pattern matcher.

Weakness: CWE-863

Which versions are affected by CVE-2026-13210?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.7.019.1.8, 19.2.6, 19.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-13210?

Upgrade gitlab to a fixed version for your release line: 19.1.8, 19.2.6 or 19.3.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-13210 being exploited?

There is no known exploitation of CVE-2026-13210 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-13210, GHSA-48pf-wfrv-7pv2, MINI-87v3-g294-5g2j, MINI-9ph5-jcpf-7g99, MINI-grfp-m9g8-gvxx.

Is CVE-2026-13210 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free