CVE-2026-1322 Business Logic Errors in GitLab

Medium 6.8 Published Updated

Authenticated users with read_api OAuth scopes can improperly create issues and comments in private projects, requiring an upgrade to GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1322?

CVE-2026-1322 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.0 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user with a read_api scoped OAuth application to create issues and add comments to issues in private projects due to improper authorization.

Weakness: CWE-840

Which versions are affected by CVE-2026-1322?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.0.018.9.7, 18.10.6, 18.11.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-1322?

Upgrade gitlab to a fixed version for your release line: 18.9.7, 18.10.6 or 18.11.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-1322 being exploited?

There is no known exploitation of CVE-2026-1322 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1322, GHSA-27g3-rwx2-w54w, UBUNTU-CVE-2026-1322.

Is CVE-2026-1322 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free