# CVE-2026-13320: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

> An authenticated user can execute arbitrary scripts in another user's browser session due to improper input sanitization in GitLab.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-gitlab-2026-13320, GHSA-m49f-rvv4-r4rv, MINI-2j33-gh3g-25f5, MINI-2xrj-jrrp-xrw9, MINI-32m5-5m8r-vjxf, MINI-358q-w327-xvhv, MINI-36gx-r97j-7532, MINI-3h6q-6qc2-jvcw, MINI-4655-j9h5-c5jp, MINI-4f2f-g4q8-cf8w, MINI-4fh3-j596-h6wh, MINI-52pm-3r9j-3794, MINI-5hjw-c72c-6qgm, MINI-5w78-j3jm-8hjp, MINI-66mh-57q8-vp7j, MINI-6mhv-228p-wqxq, MINI-7c23-gpv6-c7xf, MINI-9g3q-896j-pffw, MINI-9mx8-94v6-mr3q, MINI-c26f-w98j-539m, MINI-c83w-gp9j-4qv6, MINI-c929-p93p-ff2g, MINI-cfmx-m36g-q4rj, MINI-cm54-g7rr-73jp, MINI-cp8m-crq7-qwxf, MINI-f2x5-fj9q-f67x, MINI-f593-c9gq-wvcp, MINI-f5v6-hh88-h7j3, MINI-fgf5-gxq9-5hwc, MINI-fjw7-qh9m-jcq5, MINI-g2fh-65hj-m7wc, MINI-h4cf-m8jx-654g, MINI-j4qf-hcvg-qjqh, MINI-j578-j37c-ffxg, MINI-jxg2-g8cm-m493, MINI-jxq4-xhjq-mvrg, MINI-mf3w-cp2x-jf6p, MINI-mph7-xxqv-8mw5, MINI-p82j-p2r4-xg3f, MINI-qhqv-wrfj-q5xc, MINI-qp43-fq3f-pjgp, MINI-qwp7-m67r-8fvf, MINI-r4mq-j9jh-vjj2, MINI-r7c3-63jg-55j4, MINI-rwg2-3g7q-2mqj, MINI-v32v-jhpq-xwrj, MINI-v3wp-cf55-6fm3, MINI-wh27-qxqq-cxqx, MINI-wvv4-3c49-7mrw, MINI-xr3v-cmjp-wpgm, UBUNTU-CVE-2026-13320

## What is CVE-2026-13320?

CVE-2026-13320 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.7 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user to execute arbitrary scripts in another user's browser session due to improper sanitization of user-supplied input.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-13320?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 15.7.0 | 18.11.7, 19.0.4, 19.1.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-13320?

Upgrade gitlab to a fixed version for your release line: 18.11.7, 19.0.4 or 19.1.2.

## Is CVE-2026-13320 being exploited?

There is no known exploitation of CVE-2026-13320 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-13320 and fix it if it is affected.

What it is: CVE-2026-13320 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-13320 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 15.7.0; fixed in 18.11.7, 19.0.4, 19.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-13320/ (Markdown: https://insights.sbomify.com/CVE-2026-13320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-13320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-13320
- OSV: https://osv.dev/vulnerability/CVE-2026-13320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-13320/
Summaries are generated and may contain mistakes; the official description above is the record.
