# CVE-2026-1337: Insufficient escaping of unicode characters in query log

> Attackers can inject malicious scripts into Neo4j query logs, leading to XSS if logs are viewed in HTML-capable tools.

- **Severity:** Low 1.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** BIT-neo4j-2026-1337, BIT-neo4j-enterprise-2026-1337, GHSA-xr72-g735-4vwp, MINI-2j72-cw9j-vw22, MINI-73hp-j53f-6j47, MINI-9c4m-h2x2-hrx9, MINI-cpg3-6j8q-6xwf, MINI-fjqp-r56f-m7pw, MINI-j74q-98cq-ph4q, MINI-q848-xx3m-cm58, MINI-rh75-rr4w-5fcq, MINI-wgv5-x6qq-2839, MINI-wwrp-m64g-3m4x

## What is CVE-2026-1337?

CVE-2026-1337 is a low-severity cross-site scripting vulnerability in neo4j Community Edition, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Insufficient escaping of unicode characters in query log in Neo4j Enterprise and Community editions prior to 2026.01 can lead to XSS if the user opens the logs in a tool that treats them as HTML. There is no security impact on Neo4j products, but this advisory is released as a precaution to treat the logs as plain text if using versions prior to 2026.01.

Proof of concept exploit:  https://github.com/JoakimBulow/CVE-2026-1337

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2026-1337?

4 open source packages ship an affected version, including org.neo4j:neo4j, neo4j and neo4j-enterprise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.neo4j:neo4j` | Maven | All versions | 2026.01 |
| `org.neo4j:neo4j` | Maven | All versions | 2026.01 |
| `neo4j` | Bitnami | All versions | 2026.1.0 |
| `neo4j-enterprise` | Bitnami | All versions | 2026.1.0 |

Products: Neo4j Neo4j.

## How do I fix CVE-2026-1337?

Upgrade org.neo4j:neo4j to 2026.01 or later.

## Is CVE-2026-1337 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1337 exists.

Public exploit code:

- CVE-2026-1337 - Neo4j - Log Injection (github_poc): https://github.com/JoakimBulow/CVE-2026-1337
- A prompt injection in a code‑review bot that executes AI‑generated fixes in a sandbox. The sandbox uses a blacklist to prevent dangerous commands, but a polyglot payload bypasses the filter and achieves remote code execution. (github_poc): https://github.com/George0Papasotiriou/CVE-2026-1337-AI-Coding-Assistant-Prompt-Injection-to-Sandbox-Escape

## Other vulnerabilities in neo4j Community Edition

- [CVE-2021-34371](https://insights.sbomify.com/CVE-2021-34371/): Deserialization of Untrusted Data in Neo4j (critical 9.8)
- [CVE-2018-18389](https://insights.sbomify.com/CVE-2018-18389/): Incorrect access control in Neo4j Enterprise Database Server via LDAP authentication (critical 9.8)
- [CVE-2013-7259](https://insights.sbomify.com/CVE-2013-7259/): Neo4J vulnerable to Cross-Site Request Forgery (medium 6.8)
- [CVE-2024-34517](https://insights.sbomify.com/CVE-2024-34517/): Neo4j Cypher component mishandles IMMUTABLE privileges (medium 6.5)
- [CVE-2026-14587](https://insights.sbomify.com/CVE-2026-14587/): Unathenticated connection can hold Bolt channel open (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1337 and fix it if it is affected.

What it is: CVE-2026-1337 is a low-severity cross-site scripting vulnerability in neo4j Community Edition, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1337 exists.

Affected packages and fixed versions:
- org.neo4j:neo4j (Maven): affected all versions; fixed in 2026.01
- org.neo4j:neo4j (Maven): affected all versions; fixed in 2026.01
- neo4j (Bitnami): affected all versions; fixed in 2026.1.0
- neo4j-enterprise (Bitnami): affected all versions; fixed in 2026.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1337/ (Markdown: https://insights.sbomify.com/CVE-2026-1337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1337
- OSV: https://osv.dev/vulnerability/CVE-2026-1337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1337/
Summaries are generated and may contain mistakes; the official description above is the record.
