CVE-2026-13506 Lazy ASN.1 sequence forcing resets nesting-depth guard
Attackers can cause denial of service in applications using Bouncy Castle for Java by exploiting a flaw in ASN.1 sequence parsing that bypasses nesting-depth limits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-13506?
CVE-2026-13506 is a high-severity denial of service vulnerability in Bouncycastle Bc-Java, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Bouncy Castle for Java before 1.85, Lazy ASN.1 sequence forcing resets nesting-depth guard. This issue also affects Bouncy Castle for Java LTS before 2.73.12, and Bouncy Castle for Java FIPS (BC-FJA) before bc-fips 1.0.2.7 (1.0.X series), 2.0.2 (2.0.X series) and 2.1.3 (2.1.X series).
Weakness: CWE-674
Which versions are affected by CVE-2026-13506?
12 open source packages ship an affected version, including org.bouncycastle:bc-fips, org.bouncycastle:bcprov-jdk15to18 and org.bouncycastle:bcprov-jdk18on. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.bouncycastle:bc-fips Maven | All versions | 1.0.2.7 |
org.bouncycastle:bc-fips Maven | All versions | 1.0.2.7 |
org.bouncycastle:bc-fips Maven | From 2.0.0 | 2.0.2 |
org.bouncycastle:bc-fips Maven | From 2.0.0 | 2.0.2 |
org.bouncycastle:bc-fips Maven | From 2.1.0 | 2.1.3 |
org.bouncycastle:bc-fips Maven | From 2.1.0 | 2.1.3 |
6 more packages
org.bouncycastle:bcprov-jdk15to18 Maven | All versions | 1.85 |
org.bouncycastle:bcprov-jdk15to18 Maven | All versions | 1.85 |
org.bouncycastle:bcprov-jdk18on Maven | All versions | 1.85 |
org.bouncycastle:bcprov-jdk18on Maven | All versions | 1.85 |
org.bouncycastle:bcprov-lts8on Maven | All versions | 2.73.12 |
org.bouncycastle:bcprov-lts8on Maven | All versions | 2.73.12 |
Products include Bouncycastle Bc-Java, Bouncycastle Bouncy Castle for Java Lts, Bouncycastle Fips Java Api.
How do I fix CVE-2026-13506?
Upgrade org.bouncycastle:bc-fips to a fixed version for your release line: 1.0.2.7, 2.0.2 or 2.1.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-13506 being exploited?
There is no known exploitation of CVE-2026-13506 in the wild and no public exploit code.
Other vulnerabilities in Bouncycastle Bc-Java
- CVE-2007-6721 Legion of the Bouncy Castle Java Cryptography API Bleichenbacher Oracle Vulnerability
- CVE-2018-1000613 Deserialization of Untrusted Data in Bouncy castle
- CVE-2026-58062 Stapled OCSP response accepted without binding to the checked certificate
- CVE-2026-59638 JSSE hostname verifier CN-fallback enabled by default despite documented opt-in
- CVE-2026-59650 MTI/A0 DH agreement exponentiates unvalidated peer value
Sources
Also known as CLEANSTART-2026-EQ05697, CLEANSTART-2026-FG50874, CLEANSTART-2026-RY43720, CLEANSTART-2026-VR91696, CLEANSTART-2026-WY53810, CLSA-2026-1792693862 and 69 more.