CVE-2026-13676 fast-uri vulnerable to host confusion via failed IDN canonicalization
Attackers can bypass host-based security policies in applications using fast-uri by exploiting IDN canonicalization failures, leading to potential SSRF or access control bypasses.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-13676?
CVE-2026-13676 is a high-severity vulnerability in fast-uri, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri versions 2.3.1 through 3.1.2 and 4.0.0 fail to canonicalize Unicode (IDN) hostnames for HTTP-family URLs. The IDN conversion path calls a helper that does not exist on the global URL constructor, silently leaving the host in its original Unicode form while normalize() and equal() still return values that differ from a WHATWG-compatible URL parser. Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering, redirect validation, outbound proxy routing) before passing the same URL to Node's URL or fetch can be bypassed when the two implementations resolve the same input to different hosts. Patches: upgrade to fast-uri 3.1.3 for the 3.x line or 4.0.1 for the 4.x line. Workarounds: enforce host policy using the same URL parser used for the actual request, or reject non-ASCII hosts before policy checks.
Which versions are affected by CVE-2026-13676?
6 open source packages ship an affected version, including fast-uri. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | From 2.3.1 | 2.4.2 |
fast-uri npm | From 2.3.1 | 2.4.2 |
fast-uri npm | From 3.0.0 | 3.1.3 |
fast-uri npm | From 3.0.0 | 3.1.3 |
fast-uri npm | From 4.0.0 | 4.0.1 |
fast-uri npm | From 4.0.0 | 4.0.1 |
Linux distribution packages (2)
python-pydata-sphinx-theme openSUSE:Leap 16.0 | All versions | 0.16.1-bp160.3.1 |
python-pydata-sphinx-theme openSUSE:Tumbleweed | All versions | 0.19.0-2.1 |
Products include Openjsf Fast-Uri.
How do I fix CVE-2026-13676?
Upgrade fast-uri to a fixed version for your release line: 2.4.2, 3.1.3 or 4.0.1.
Is CVE-2026-13676 being exploited?
There is no known exploitation of CVE-2026-13676 in the wild and no public exploit code.
Other vulnerabilities in fast-uri
- CVE-2026-84292 fast-uri vulnerable to authority injection via an unvalidated port in serialize
- CVE-2026-84394 fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority
- CVE-2026-75899 fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding
- CVE-2026-75931 fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
- CVE-2026-75975 fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
Sources
Also known as CLEANSTART-2026-AM69167, CLEANSTART-2026-QX93902, CLSA-2026-1792402819, DEBIAN-CVE-2026-13676, ECHO-d097-f100-ef64, GHSA-4c8g-83qw-93j6 and 41 more.