CVE-2026-13697 undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives
Attackers can leak private response data across users or crash the application via malformed Cache-Control headers in undici's cache interceptor.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-13697?
CVE-2026-13697 is a high-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici's cache interceptor mishandles malformed Cache-Control private directives. In undici 7.0.0 up to before 7.29.0 and 8.0.0 up to before 8.9.0, a response carrying a degenerate qualified private directive, such as private set to an empty value, can be stored in the default shared cache and later served to a different caller with the same cache key, disclosing private response bodies and headers including Set-Cookie. Separately, a Cache-Control header that combines an unqualified private directive with a qualified one triggers an uncaught TypeError in the cache-control parser, which rejects the request and, depending on the consumer's error handling, can terminate the process. Both issues affect applications using the cache interceptor in shared mode, including the default configuration. The issues are fixed in undici 7.29.0 and 8.9.0.
Which versions are affected by CVE-2026-13697?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 7.0.0 | 7.29.0 |
undici npm | From 8.0.0 | 8.9.0 |
undici npm | From 8.0.0 | 8.9.0 |
Products include Nodejs Undici.
How do I fix CVE-2026-13697?
Upgrade undici to a fixed version for your release line: 7.29.0 or 8.9.0.
Is CVE-2026-13697 being exploited?
There is no known exploitation of CVE-2026-13697 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-CD82080, CLEANSTART-2026-KO94140, CLEANSTART-2026-QU92900, CLSA-2026-1790542520, DEBIAN-CVE-2026-13697, ECHO-b91c-97c9-b93d and 17 more.