# CVE-2026-13697: undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives

> Attackers can leak private response data across users or crash the application via malformed Cache-Control headers in undici's cache interceptor.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Also known as:** CLEANSTART-2026-CD82080, CLEANSTART-2026-KO94140, CLEANSTART-2026-QU92900, CLSA-2026-1790542520, DEBIAN-CVE-2026-13697, ECHO-b91c-97c9-b93d, GHSA-4cwx-7wf7-3272, MINI-2gpj-mq63-8mhw, MINI-6wpm-3vcj-g5v3, MINI-7jr5-57mm-5xv4, MINI-8xhf-hv33-8fh6, MINI-c464-488w-mj3v, MINI-ff8c-24wc-5v9r, MINI-jchp-764q-xvhj, MINI-p2h4-jgcv-fmrc, MINI-p79w-5prv-52hj, MINI-q274-x8q8-7fjc, MINI-qpgh-8pgc-gcg4, MINI-qrj4-vg2r-x24v, MINI-r5c8-8456-rrvm, MINI-xcjj-5vcj-w3mm, ROOT-APP-NPM-CVE-2026-13697, UBUNTU-CVE-2026-13697

## What is CVE-2026-13697?

CVE-2026-13697 is a high-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's cache interceptor mishandles malformed Cache-Control private directives. In undici 7.0.0 up to before 7.29.0 and 8.0.0 up to before 8.9.0, a response carrying a degenerate qualified private directive, such as private set to an empty value, can be stored in the default shared cache and later served to a different caller with the same cache key, disclosing private response bodies and headers including Set-Cookie. Separately, a Cache-Control header that combines an unqualified private directive with a qualified one triggers an uncaught TypeError in the cache-control parser, which rejects the request and, depending on the consumer's error handling, can terminate the process. Both issues affect applications using the cache interceptor in shared mode, including the default configuration. The issues are fixed in undici 7.29.0 and 8.9.0.

Weakness: CWE-525 (Use of Web Browser Cache Containing Sensitive Information), CWE-248 (Uncaught Exception), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-13697?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 7.0.0 | 7.29.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |
| `undici` | npm | From 8.0.0 | 8.9.0 |

Products: Nodejs Undici.

## How do I fix CVE-2026-13697?

Upgrade undici to a fixed version for your release line: 7.29.0 or 8.9.0.

## Is CVE-2026-13697 being exploited?

There is no known exploitation of CVE-2026-13697 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-13697 and fix it if it is affected.

What it is: CVE-2026-13697 is a high-severity vulnerability in Nodejs Undici, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-13697 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 7.0.0; fixed in 7.29.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0
- undici (npm): affected from 8.0.0; fixed in 8.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-13697/ (Markdown: https://insights.sbomify.com/CVE-2026-13697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-13697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-13697
- OSV: https://osv.dev/vulnerability/CVE-2026-13697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-13697/
Summaries are generated and may contain mistakes; the official description above is the record.
