# CVE-2026-13760: OS Command Injection in aws-cdk-lib Docker Bundling

> Attackers controlling package.json dependency strings can execute arbitrary commands on the host during CDK Docker bundling.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 1 Jul 2026
- **Also known as:** GHSA-vcrf-j523-4mrf

## What is CVE-2026-13760?

CVE-2026-13760 is a high-severity command injection vulnerability in AWS CDK, published on 1 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OS command injection in the NodejsFunction Docker bundling pipeline (OsCommand helper) in AWS aws-cdk-lib on all platforms might allow a actor who controls dependency version strings in a project's package.json file to execute arbitrary commands on the host running the CDK toolchain via injected shell metacharacters in the OsCommand helper. This issue requires the actor to control the content of a package.json dependency version string that is processed during Docker-based bundling with nodeModules specified.

To remediate this issue, users should upgrade to v2.260.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-13760?

2 open source packages ship an affected version, including aws-cdk-lib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-cdk-lib` | npm | All versions | 2.260.0 |
| `aws-cdk-lib` | npm | All versions | 2.260.0 |

## How do I fix CVE-2026-13760?

Upgrade aws-cdk-lib to 2.260.0 or later.

## Is CVE-2026-13760 being exploited?

There is no known exploitation of CVE-2026-13760 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-13760 and fix it if it is affected.

What it is: CVE-2026-13760 is a high-severity command injection vulnerability in AWS CDK, published on 1 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-13760 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-cdk-lib (npm): affected all versions; fixed in 2.260.0
- aws-cdk-lib (npm): affected all versions; fixed in 2.260.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-13760/ (Markdown: https://insights.sbomify.com/CVE-2026-13760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-13760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-13760
- OSV: https://osv.dev/vulnerability/CVE-2026-13760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-13760/
Summaries are generated and may contain mistakes; the official description above is the record.
