CVE-2026-13769 Overly permissive File Permissions in AWS CLI

Medium 6.8 Published Updated

Local attackers can read AWS credentials due to overly permissive file permissions in specific CLI subcommands when system umask is not restricted.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-13769?

CVE-2026-13769 is a medium-severity vulnerability in AWS CLI, published on 1 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register).

To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.

Weakness: CWE-732

Which versions are affected by CVE-2026-13769?

3 open source packages ship an affected version, including awscli. It affects 1 product.

PackageAffectedFixed in
awscli PyPIAll versions1.44.78
awscli PyPIAll versions1.44.78
awscli PyPIAll versions1.44.78

Products include Amazon Aws Command Line Interface.

How do I fix CVE-2026-13769?

Upgrade awscli to 1.44.78 or later.

Is CVE-2026-13769 being exploited?

There is no known exploitation of CVE-2026-13769 in the wild and no public exploit code.

Sources

Also known as GHSA-wfp6-f47h-hxc3, MINI-m5p5-j4cw-m96f, MINI-vgjx-pjxf-vgv7, PYSEC-2026-3548.

Is CVE-2026-13769 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free