{"answers":{"affected":"3 open source packages ship an affected version, including awscli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-13769 in the wild and no public exploit code.","fix":"Upgrade awscli to 1.44.78 or later.","what":"CVE-2026-13769 is a medium-severity vulnerability in AWS CLI, published on 1 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-13769 and fix it if it is affected.\n\nWhat it is: CVE-2026-13769 is a medium-severity vulnerability in AWS CLI, published on 1 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-13769 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- awscli (PyPI): affected all versions; fixed in 1.44.78\n- awscli (PyPI): affected all versions; fixed in 1.44.78\n- awscli (PyPI): affected all versions; fixed in 1.44.78\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-13769/ (Markdown: https://insights.sbomify.com/CVE-2026-13769/index.md)","id":"CVE-2026-13769","markdown":"https://insights.sbomify.com/CVE-2026-13769/index.md","name":"CVE-2026-13769","record":{"aliases":["GHSA-wfp6-f47h-hxc3","MINI-m5p5-j4cw-m96f","MINI-vgjx-pjxf-vgv7","PYSEC-2026-3548"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"AWS CLI","requires_auth":"low_privilege","summary":"Local attackers can read AWS credentials due to overly permissive file permissions in specific CLI subcommands when system umask is not restricted.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"aws_command_line_interface","vendor":"amazon"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register).\n\nTo remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Overly permissive File Permissions in AWS CLI","id":"CVE-2026-13769","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"AppMySite \u003c= 3.15.3 - Authenticated (Subscriber+) Stored Cross-Site Scripting via save_ams_license_key AJAX Handler","id":"CVE-2026-13770"},"packages":[{"ecosystem":"PyPI","fixed":["1.44.78"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":null,"source":"GHSA-wfp6-f47h-hxc3"},{"ecosystem":"PyPI","fixed":["1.44.78"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":"pkg:pypi/awscli","source":"GHSA-wfp6-f47h-hxc3"},{"ecosystem":"PyPI","fixed":["1.44.78"],"introduced":["0"],"last_affected":[],"package":"awscli","purl":"pkg:pypi/awscli","source":"PYSEC-2026-3548"}],"prev":{"headline":"Gardyn IoT Hub Use of Hard-coded Credentials","id":"CVE-2026-13768"},"products":["AWS CLI"],"published":"2026-07-01","related":[{"cvss_score":6.9,"headline":"Disabled SSH host key verification in Amazon AWS CLI EMR helper commands","id":"CVE-2026-18654","kev_date_added":null,"published":"2026-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-01","vendors":["AWS"]},"summary":"Local attackers can read AWS credentials due to overly permissive file permissions in specific CLI subcommands when system umask is not restricted.","url":"https://insights.sbomify.com/CVE-2026-13769/"}