# CVE-2026-13769: Overly permissive File Permissions in AWS CLI

> Local attackers can read AWS credentials due to overly permissive file permissions in specific CLI subcommands when system umask is not restricted.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 1 Jul 2026
- **Also known as:** GHSA-wfp6-f47h-hxc3, MINI-m5p5-j4cw-m96f, MINI-vgjx-pjxf-vgv7, PYSEC-2026-3548

## What is CVE-2026-13769?

CVE-2026-13769 is a medium-severity vulnerability in AWS CLI, published on 1 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Overly permissive file permissions in AWS CLI before 1.44.78 (v1) and 2.34.29 (v2) on Unix-like systems where the umask has not been configured to restrict file permissions (the default on most systems) may allow other local users on the same host to read credentials written by certain CLI subcommands (aws codeartifact login, aws iam create-virtual-mfa-device, aws deploy register).

To remediate this issue, users should upgrade to AWS CLI 1.44.78 (v1) or 2.34.29 (v2) or later.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2026-13769?

3 open source packages ship an affected version, including awscli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awscli` | PyPI | All versions | 1.44.78 |
| `awscli` | PyPI | All versions | 1.44.78 |
| `awscli` | PyPI | All versions | 1.44.78 |

Products: Amazon Aws Command Line Interface.

## How do I fix CVE-2026-13769?

Upgrade awscli to 1.44.78 or later.

## Is CVE-2026-13769 being exploited?

There is no known exploitation of CVE-2026-13769 in the wild and no public exploit code.

## Other vulnerabilities in AWS CLI

- [CVE-2026-18654](https://insights.sbomify.com/CVE-2026-18654/): Disabled SSH host key verification in Amazon AWS CLI EMR helper commands (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-13769 and fix it if it is affected.

What it is: CVE-2026-13769 is a medium-severity vulnerability in AWS CLI, published on 1 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-13769 in the wild and no public exploit code.

Affected packages and fixed versions:
- awscli (PyPI): affected all versions; fixed in 1.44.78
- awscli (PyPI): affected all versions; fixed in 1.44.78
- awscli (PyPI): affected all versions; fixed in 1.44.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-13769/ (Markdown: https://insights.sbomify.com/CVE-2026-13769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-13769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-13769
- OSV: https://osv.dev/vulnerability/CVE-2026-13769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-13769/
Summaries are generated and may contain mistakes; the official description above is the record.
