CVE-2026-1388 Inefficient Regular Expression Complexity in GitLab

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service via ReDoS in GitLab merge request endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1388?

CVE-2026-1388 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 9.2 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthenticated user to cause regular expression denial of service by sending specially crafted input to a merge request endpoint under certain conditions.

Weakness: CWE-1333

Which versions are affected by CVE-2026-1388?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.2.018.7.5, 18.8.5, 18.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-1388?

Upgrade gitlab to a fixed version for your release line: 18.7.5, 18.8.5 or 18.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1388 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1388 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1388, GHSA-35pf-5r93-c5jc, UBUNTU-CVE-2026-1388.

Is CVE-2026-1388 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free