CVE-2026-1402 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a denial of service in GitLab due to insufficient resource validation, requiring an upgrade to remediate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1402?

CVE-2026-1402 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.10.7, 18.11 before 18.11.4, and 19.0 before 19.0.1 that under certain conditions could have allowed an authenticated user to cause denial of service due to insufficient validation.

Weakness: CWE-770

Which versions are affected by CVE-2026-1402?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.1.018.10.7, 18.11.4, 19.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-1402?

Upgrade gitlab to a fixed version for your release line: 18.10.7, 18.11.4 or 19.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1402 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1402 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1402, GHSA-wgq9-qp63-g8j3, MINI-32qq-6g9c-237h, MINI-355c-pmwr-vcpc, MINI-37fx-pwmg-fv5m, MINI-39qv-f9p6-c9q7 and 39 more.

Is CVE-2026-1402 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free