{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1402 exists.","fix":"Upgrade gitlab to a fixed version for your release line: 18.10.7, 18.11.4 or 19.0.2.","what":"CVE-2026-1402 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1402 and fix it if it is affected.\n\nWhat it is: CVE-2026-1402 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1402 exists.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 17.1.0; fixed in 18.10.7, 18.11.4, 19.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1402/ (Markdown: https://insights.sbomify.com/CVE-2026-1402/index.md)","id":"CVE-2026-1402","markdown":"https://insights.sbomify.com/CVE-2026-1402/index.md","name":"CVE-2026-1402","record":{"aliases":["BIT-gitlab-2026-1402","GHSA-wgq9-qp63-g8j3","MINI-32qq-6g9c-237h","MINI-355c-pmwr-vcpc","MINI-37fx-pwmg-fv5m","MINI-39qv-f9p6-c9q7","MINI-3mgf-xg8f-7fwh","MINI-42vj-g83j-qxj4","MINI-478c-55rm-6f6q","MINI-4gw5-m4mr-qr6w","MINI-57hw-hwqj-w7g5","MINI-5cvf-v3vf-f5gq","MINI-5hhm-5m6j-ffrx","MINI-7rx2-wjxg-gx23","MINI-8mfc-6m95-4vxq","MINI-8qm6-r654-w6rr","MINI-93v8-p453-7mhv","MINI-c6cw-fcmf-vhmh","MINI-c6gx-2pp3-4xcf","MINI-cvcg-vm2c-m25q","MINI-gcjg-rx39-g628","MINI-gg34-53hm-22v3","MINI-gmpq-7w7w-pg62","MINI-h638-cqgw-3m8h","MINI-h9vr-x54w-gjmf","MINI-hcw2-mq8x-mfjv","MINI-j7rj-962x-mjpv","MINI-j7ww-fmpw-hm6r","MINI-jh89-9cg6-hvp6","MINI-jwmr-hqrp-9h3f","MINI-mxqw-rwxx-hv74","MINI-pp4q-4rq5-w4r8","MINI-q7fp-v4g9-5fwg","MINI-qwgq-mvwf-5g28","MINI-qxx2-389c-7gwc","MINI-rrj5-8hjg-w8qg","MINI-v97r-8f34-3rxh","MINI-vc84-cv5f-4c58","MINI-wp28-qcvg-f7fr","MINI-wvww-xg55-6whp","MINI-x5mc-hcxv-2ffr","MINI-x849-whgx-rhx5","MINI-xg69-8g7j-p46v","MINI-xvpj-56fg-2fmr","UBUNTU-CVE-2026-1402"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GitLab","requires_auth":"low_privilege","summary":"An authenticated user can cause a denial of service in GitLab due to insufficient resource validation, requiring an upgrade to remediate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.10.7, 18.11 before 18.11.4, and 19.0 before 19.0.1 that under certain conditions could have allowed an authenticated user to cause denial of service due to insufficient validation.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Allocation of Resources Without Limits or Throttling in GitLab","id":"CVE-2026-1402","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"Allocation of Resources Without Limits or Throttling in GitLab","id":"CVE-2026-1403"},"packages":[{"ecosystem":"Bitnami","fixed":["18.10.7","18.11.4","19.0.2"],"introduced":["17.1.0","18.11.0","19.0.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2026-1402"}],"prev":{"headline":"Tune Library \u003c= 1.6.3 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting via CSV Import","id":"CVE-2026-1401"},"products":["GitLab"],"published":"2026-05-27","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-27","vendors":["GitLab"]},"summary":"An authenticated user can cause a denial of service in GitLab due to insufficient resource validation, requiring an upgrade to remediate.","url":"https://insights.sbomify.com/CVE-2026-1402/"}