CVE-2026-14181 @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths
Attackers can crash the Node.js process via malformed percent-encoded paths when using the standalone engine API, requiring an upgrade or migration to the plugin path.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-14181?
CVE-2026-14181 is a high-severity denial of service vulnerability in @fastify/middie, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@fastify/middie versions 9.1.0 through 9.3.2 fail to guard the URL normalization step used by the standalone engine when incoming request paths contain malformed percent-encoded sequences. Inputs such as an incomplete percent escape or a truncated multibyte sequence cause the underlying decoder to throw synchronously, and the exception escapes the middie normalize step and terminates the Node.js process. The bypass affects applications that call middie.run directly on the standalone engine API, causing an immediate denial of service for all connected clients until restart. Applications using the Fastify plugin path are not affected because Fastifys error handler catches the exception. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: migrate from the standalone engine API to the Fastify plugin path, where the framework error handler catches the exception.
Weakness: CWE-248
Which versions are affected by CVE-2026-14181?
It affects 1 product.
Products include Fastify Fastify\/Middie.
How do I fix CVE-2026-14181?
No fix has been published for CVE-2026-14181 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-14181 being exploited?
There is no known exploitation of CVE-2026-14181 in the wild and no public exploit code.
Other vulnerabilities in @fastify/middie
- CVE-2026-85184 @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
- CVE-2026-14198 @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values
- CVE-2026-6270 @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
- CVE-2026-22031 Fastify Middie Middleware Path Bypass
- CVE-2026-2880 @fastify/middie has an improper path normalization vulnerability
Sources
Also known as GHSA-qcc9-jh8q-47vh.