{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-14181 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-14181 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-14181 is a high-severity denial of service vulnerability in @fastify/middie, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-14181 and fix it if it is affected.\n\nWhat it is: CVE-2026-14181 is a high-severity denial of service vulnerability in @fastify/middie, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-14181 in the wild and no public exploit code.\n\nAffected product: @fastify/middie. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-14181/ (Markdown: https://insights.sbomify.com/CVE-2026-14181/index.md)","id":"CVE-2026-14181","markdown":"https://insights.sbomify.com/CVE-2026-14181/index.md","name":"CVE-2026-14181","record":{"aliases":["GHSA-qcc9-jh8q-47vh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Fastify middleware library","requires_auth":"none","summary":"Attackers can crash the Node.js process via malformed percent-encoded paths when using the standalone engine API, requiring an upgrade or migration to the plugin path.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/middie","vendor":"fastify"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"@fastify/middie versions 9.1.0 through 9.3.2 fail to guard the URL normalization step used by the standalone engine when incoming request paths contain malformed percent-encoded sequences. Inputs such as an incomplete percent escape or a truncated multibyte sequence cause the underlying decoder to throw synchronously, and the exception escapes the middie normalize step and terminates the Node.js process. The bypass affects applications that call middie.run directly on the standalone engine API, causing an immediate denial of service for all connected clients until restart. Applications using the Fastify plugin path are not affected because Fastifys error handler catches the exception. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: migrate from the standalone engine API to the Fastify plugin path, where the framework error handler catches the exception.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths","id":"CVE-2026-14181","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Auth bypass in Customer Email Verification for WooCommerce","id":"CVE-2026-14182"},"packages":[],"prev":{"headline":"Undertow-core: undertow:http request smuggling via oversized chunk-size bit overlap","id":"CVE-2026-14180"},"products":["@fastify/middie"],"published":"2026-07-01","related":[{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target","id":"CVE-2026-85184","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values","id":"CVE-2026-14198","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes","id":"CVE-2026-6270","kev_date_added":null,"published":"2026-04-16"},{"cvss_score":8.4,"headline":"Fastify Middie Middleware Path Bypass","id":"CVE-2026-22031","kev_date_added":null,"published":"2026-01-19"},{"cvss_score":8.2,"headline":"@fastify/middie has an improper path normalization vulnerability","id":"CVE-2026-2880","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.4,"headline":"@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option","id":"CVE-2026-33804","kev_date_added":null,"published":"2026-04-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-01","vendors":["@fastify/middie"]},"summary":"Attackers can crash the Node.js process via malformed percent-encoded paths when using the standalone engine API, requiring an upgrade or migration to the plugin path.","url":"https://insights.sbomify.com/CVE-2026-14181/"}