# CVE-2026-14198: @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values

> Attackers can bypass authentication or authorization checks in @fastify/middie by using encoded slashes in path parameters, allowing unauthorized access to protected handlers.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Jul 2026
- **Updated:** 1 Jul 2026
- **Also known as:** GHSA-2v46-jxjm-7q3v

## What is CVE-2026-14198?

CVE-2026-14198 is a critical authentication bypass vulnerability in @fastify/middie, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/middie versions 9.1.0 through 9.3.2 decode the encoded slash %2F inside path parameter values before matching middleware paths, while Fastify's underlying router preserves the encoding during route lookup. The two layers disagree on the canonical request path, so the middleware fails to match a URL that the route handler does match. When middleware is used for authentication, authorization, rate limiting, or auditing on parameterized paths, an attacker can reach the protected handler by sending a single crafted URL with an encoded slash in the parameter position. The bypass is HTTP method agnostic and requires no authentication or special preconditions. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: avoid parameterized middleware paths for security decisions, or enforce authentication at the route handler or via a Fastify hook that runs after the router has resolved the request.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-14198?

It affects 1 product.


Products: Fastify Fastify\/Middie.

## How do I fix CVE-2026-14198?

No fix has been published for CVE-2026-14198 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-14198 being exploited?

There is no known exploitation of CVE-2026-14198 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/middie

- [CVE-2026-85184](https://insights.sbomify.com/CVE-2026-85184/): @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target (critical 9.1)
- [CVE-2026-6270](https://insights.sbomify.com/CVE-2026-6270/): @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes (critical 9.1)
- [CVE-2026-22031](https://insights.sbomify.com/CVE-2026-22031/): Fastify Middie Middleware Path Bypass (high 8.4)
- [CVE-2026-2880](https://insights.sbomify.com/CVE-2026-2880/): @fastify/middie has an improper path normalization vulnerability (high 8.2)
- [CVE-2026-14181](https://insights.sbomify.com/CVE-2026-14181/): @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-14198 and fix it if it is affected.

What it is: CVE-2026-14198 is a critical authentication bypass vulnerability in @fastify/middie, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-14198 in the wild and no public exploit code.

Affected product: @fastify/middie. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-14198/ (Markdown: https://insights.sbomify.com/CVE-2026-14198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-14198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-14198
- OSV: https://osv.dev/vulnerability/CVE-2026-14198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-14198/
Summaries are generated and may contain mistakes; the official description above is the record.
