CVE-2026-14257 brace-expansion DoS via unbounded expansion length causing an out-of-memory process crash
An attacker can crash a Node.js process by providing crafted input to the brace-expansion library, causing memory exhaustion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-14257?
CVE-2026-14257 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 23 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.
Which versions are affected by CVE-2026-14257?
8 open source packages ship an affected version, including brace-expansion. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
brace-expansion npm | All versions | 1.1.17 |
brace-expansion npm | All versions | 1.1.17 |
brace-expansion npm | From 2.0.0 | 2.1.3 |
brace-expansion npm | From 2.0.0 | 2.1.3 |
brace-expansion npm | From 3.0.0 | 3.0.3 |
brace-expansion npm | From 3.0.0 | 3.0.3 |
2 more packages
brace-expansion npm | From 4.0.0 | 5.0.8 |
brace-expansion npm | From 4.0.0 | 5.0.8 |
Products include Juliangruber Brace-Expansion.
How do I fix CVE-2026-14257?
Upgrade brace-expansion to a fixed version for your release line: 1.1.17, 2.1.3, 3.0.3 or 5.0.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-14257 being exploited?
There is no known exploitation of CVE-2026-14257 in the wild and no public exploit code.
Other vulnerabilities in juliangruber brace-expansion
Sources
Also known as AZL-94520, AZL-94535, CLEANSTART-2026-EH67638, CLEANSTART-2026-IZ75893, CLEANSTART-2026-JX26163, CLEANSTART-2026-NJ03558 and 55 more.